Данный веб-сайт использует файлы cookie для того, чтобы сохранить данные на вашем компьютере. Если вы продолжаете работать с этим веб-сайтом, мы предполагаем, что вы соглашаетесь с использованием файлов cookie.
Diese Seite verwendet Cookies, um Ihnen den bestmöglichen Service zu gewährleisten. Wenn Sie auf der Seite weitersurfen stimmen Sie der Cookie-Nutzung zu.
Cookies remember you so we can give you a better service online. By using this website or closing this message, you are agreeing to our Cookies notice.
This site uses cookies to give you the best service possible. If you continue browsing, you agree to the use of cookies. Cookies remember you so we can give you a better service online. By using this website or closing this message, you are agreeing to our cookies notice.

SmsGateWay24.com Your personal sms gateway

Documentation | SmsGateway24.com Postman link


If your service does not support sending a request via SSL (via https), then you can use the HTTP protocol

Getting a token

Beschreibung: The result of this query you get a token. In the future, with this token, you access the server and perform other requests.

Address https://smsgateway24.com/getdata/gettoken

Now your token: Login

Method: POST

входные параметры

Variable Type Beschreibung
email string Your login in the system. Usually email
pass string Your password in the system

Answer

Variable Type Beschreibung
token string Your token for requests. Token is associated with an account
error number 0 / 1 - gibt es einen Fehler bei der Verarbeitung der Anfrage
message string Error message


SMS sending

Beschreibung: Creates SMS on the server to send. After that, the phone with the Smsgateway24 application calls the server and takes the SMS and sends it from your sim card Download the application at the link Link to app SmsGateWay24

Address https://smsgateway24.com/getdata/addsms

Method: POST

входные параметры

Variable Type Beschreibung
token string Your token obtained from the method Get Token
sendto string Subscriber's phone number. All required characters are allowed. example: +1- (928) -111-22-33
body string Target message body
device_id string Device ID
timetosend datetime [YYYY-mm-dd HH:MM:SS] [optional] Time to send a message. For example, 2018-10-25 00:00:00

Answer

Variable Type Beschreibung
error number 0 / 1 - gibt es einen Fehler bei der Verarbeitung der Anfrage
message string Error message


Add tag

Beschreibung: The tag is needed to create a newsletter on a group of numbers. For example, tag * Employees *.

Address https://smsgateway24.com/getdata/savetag

Method: POST

входные параметры

Variable Type Beschreibung
token string Your token obtained from the method Get Token
title string Tag name

Answer

Variable Type Beschreibung
error number 0 / 1 - gibt es einen Fehler bei der Verarbeitung der Anfrage
message string Error message
tag_id number Tag ID

Add contacts with a tag

Beschreibung: Add contacts for any tag. For example, for the tag * Employees * your colleagues will perfectly fit.

Address https://smsgateway24.com/getdata/savecontact

Method: POST

входные параметры

Variable Type Beschreibung
token string Your token obtained from the method Get Token
fullname string contact name
phone string phone number
tag_id number tag name

Answer

Variable Type Beschreibung
error number 0 / 1 - gibt es einen Fehler bei der Verarbeitung der Anfrage
message string Error message
contact_id number Contact ID

Create a Newsletter

Beschreibung: Once you have created the tag, you can do the mailing on the tag phones.

Address https://smsgateway24.com/getdata/savepaket

Method: POST

входные параметры

Variable Type Beschreibung
token string Your token obtained from the method Get Token
title string Newsletter title
device_id number Device ID
body string Target message body
tags string tag Id. can be several, separated by commas. For example: 12,13,14

Answer

Variable Type Beschreibung
error number 0 / 1 - gibt es einen Fehler bei der Verarbeitung der Anfrage
message string Error message
paket number Package ID

You can use Postman to send requests.

Postman JSON

PHP code sample

$ch = curl_init();
$url = "https://smsgateway24.com/getdata/getdata/addsms

$postarray = [
'token' => 'dsajdhjhj1ihi1',
'sendto' => '3782137192',
'body'   => 'SMS TEXT',
'timetosend'   => 'SMS TEXT',
];

 curl_setopt($ch, CURLOPT_URL, $url);
 curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
 curl_setopt($ch, CURLOPT_POST, 1);
 curl_setopt($ch, CURLOPT_POSTFIELDS,
 "postvar1=value1&postvar2=value2&postvar3=value3");
 curl_setopt($ch, CURLOPT_USERAGENT, 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13');
 $output = curl_exec($ch);
 curl_close($ch);
 echo $output;

                            

Sample code for 1C

 Процедура ГлВыполнитьОтправкуСМС(Телефон,ТекстСМС) Экспорт


Логин=СокрЛП(Константа.ЛогинСМС);
Пароль=СокрЛП(Константа.ПарольСМС);
КодУстр=СокрЛП(Константа.КодУстройстваСМС);
Получатель=СокрЛП(Телефон);
Сообщение=СокрЛП(Лев(ТекстСМС,256));
Сообщение=ГлПреобразоватьСтрокуВУТФ8(Сообщение);

ТекстЗапроса="http://smsgateway24.com/getdata/smstosend?sendto="+Получатель+"&body="+Сообщение+"&device_id="+СокрЛП(КодУстр)+"&email="+Логин+"&pass="+Пароль;
Результат="";
Если ЗагрузитьВнешнююКомпоненту("c:\v7plus.dll") <> 1 Тогда
ТекстОшибки = "Компонента v7plus.dll не найдена!";
Сообщить(ТекстОшибки);
Возврат;
КонецЕсли;

Ошибка=0;
Соединение = СоздатьОбъект("AddIn.V7HttpReader");
Попытка
Соединение.ОтправитьДляОбработки(ТекстЗапроса,каталогиб()+"\temp.txt", 1,Результат, 2);
Исключение
Ошибка=1;
Сообщить("СМС не сформировано! для телефона "+Получатель+" Ответ сервера: "+Результат);
КонецПопытки;

Если Ошибка=0 Тогда
Сообщить("ОК. СМС сформировано! для телефона "+Получатель+" Ответ сервера: "+Результат);
КонецЕсли;


КонецПроцедуры
                            

Old methods API (GET) (HTTPS + HTTP)

SMS sending

Beschreibung: Creates SMS on the server to send. After that, the phone with the Smsgateway24 application calls the server and takes the SMS and sends it from your sim card Download the application at the link: Link to app SmsGateWay24

Address https://smsgateway24.com/getdata/smstosend?sendto=PHONE&body=MESSAGE&device_id=DEVICE_ID&email=LOGIN&pass=PASSWORD

Address https://smsgateway24.com/getdata/smstosend?sendto=ТЕЛЕФОН&body=СООБЩЕНИЕ&device_id=ID_УСТРОЙСТВА&email=ЛОГИН&pass=ПАРОЛЬ&timetosend=2018-06-08 13:40:00

Method: GET

входные параметры

Variable Type Beschreibung
email string Your login in the system. Usually email
pass string your password
sendto string Subscriber's phone number. All required characters are allowed. example: +1- (928) -111-22-33
body string Target message body
device_id string Device ID
timetosend datetime [YYYY-mm-dd HH:MM:SS] [optional] Time to send a message. For example, 2018-10-25 00:00:00

Answer

"Saved" - All is OK
Access deny - wrong login or password

PHP:

$ch = curl_init();
$url = "https://smsgateway24.com/getdata/smstosend?sendto=" . $save->phone . "&body=" . $body . "&device_id=" . $device_id . "&email=support@smsgateway24.com&pass=123456";
curl_setopt($ch, CURLOPT_URL, $url);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
curl_setopt($ch, CURLOPT_USERAGENT, 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13');
$output = curl_exec($ch);
curl_close($ch);

                        

Telegram bot


If you want to send notifications to your phone via telegram, then connect our bot

Send request

Beschreibung: Send a POST request to the server and people will receive a message in a telegram

Before sending you need to do 3 steps:

  1. Download telegram from the official site Telegram.org
  2. Something to write bot @Smsgateway24bot
  3. Get your ID through the bot @MyTelegramID_bot
  4. Send POST request

Address https://smsgateway24.com/getdata/telegrammessage

Now your token: Login

Method: POST

входные параметры

Variable Type Beschreibung
token string Your token obtained from the method Get Token
body string Target message body
telegramid string Your Id to Telegram via @MyTelegramID_bot

Answer

Variable Type Beschreibung
error number 0 / 1 - gibt es einen Fehler bei der Verarbeitung der Anfrage
message string Error message