Данный веб-сайт использует файлы cookie для того, чтобы сохранить данные на вашем компьютере. Если вы продолжаете работать с этим веб-сайтом, мы предполагаем, что вы соглашаетесь с использованием файлов cookie.
Diese Seite verwendet Cookies, um Ihnen den bestmöglichen Service zu gewährleisten. Wenn Sie auf der Seite weitersurfen stimmen Sie der Cookie-Nutzung zu.
Cookies remember you so we can give you a better service online. By using this website or closing this message, you are agreeing to our Cookies notice.
This site uses cookies to give you the best service possible. If you continue browsing, you agree to the use of cookies. Cookies remember you so we can give you a better service online. By using this website or closing this message, you are agreeing to our cookies notice.

SmsGateWay24.com Ваш личный смс шлюз

Документация | SmsGateway24.com Postman ссылка


Если Ваш сервис не поддерживает отправку запроса через SSL (на https) то вы можете использовать протокол HTTP

Получение токена

Описание: Результатом этого запроса вы получаете токен. В дальнейшем с этим токеном вы обращаетесь к серверу и выполняете другие запросы.

Адрес https://smsgateway24.com/getdata/gettoken

Сейчас Ваш токен: Вход

Метод: POST

входные параметры

Переменная Тип Описание
email string Ваш логин в системе. Обычно email
pass string Ваш пароль в системе

Ответ

Переменная Тип Описание
token string Ваш токен для запросов. Токен связан с Аккаунтом
error number 0 / 1 - есть ли ошибка в обработке запроса
message string Сообщение об ошибке


Отправка смс

Описание: Создает смс на сервере для отправки. После этого телефон с приложением Smsgateway24 обращается к серверу и забирает смс и отправляет со своей sim карты. Скачать приложение можно по ссылке Ссылка на приложение SmsGateWay24

Адрес https://smsgateway24.com/getdata/addsms

Метод: POST

входные параметры

Переменная Тип Описание
token string Ваш токен полученный из метода Получение токена
sendto string Телефонный номер абонента. Допускаются все требуемые символы. пример: +7-(928)-111-22-33
body string Тело сообщения для абонента
device_id string Id Устройства
timetosend datetime [YYYY-mm-dd HH:MM:SS] [не обязательно] Время отправки сообщения Например 2018-10-25 00:00:00

Ответ

Переменная Тип Описание
error number 0 / 1 - есть ли ошибка в обработке запроса
message string Сообщение об ошибке


Добавить тэг

Описание: Тег нужен чтобы создавать рассылку на группу номеров. Например тег *Сотрудники*.

Адрес https://smsgateway24.com/getdata/savetag

Метод: POST

входные параметры

Переменная Тип Описание
token string Ваш токен полученный из метода Получение токена
title string Название тега

Ответ

Переменная Тип Описание
error number 0 / 1 - есть ли ошибка в обработке запроса
message string Сообщение об ошибке
tag_id number ID тега

Добавить контакты с тегом

Описание: Добавляйте контакты для какого нибудь тега. Например для тега *Сотрудники* отлично подойдут ваши коллеги.

Адрес https://smsgateway24.com/getdata/savecontact

Метод: POST

входные параметры

Переменная Тип Описание
token string Ваш токен полученный из метода Получение токена
fullname string имя контакта
phone string номер телефона
tag_id number имя тега

Ответ

Переменная Тип Описание
error number 0 / 1 - есть ли ошибка в обработке запроса
message string Сообщение об ошибке
contact_id number ID контакта

Создать рассылку

Описание: После того как вы создали тег, вы можете сделать рассылку на телефоны тега.

Адрес https://smsgateway24.com/getdata/savepaket

Метод: POST

входные параметры

Переменная Тип Описание
token string Ваш токен полученный из метода Получение токена
title string имя рассылки
device_id number Id Устройства
body string Тело сообщения для абонента
tags string Id тега. можно сразу несколько, через запятую. Например: 12,13,14

Ответ

Переменная Тип Описание
error number 0 / 1 - есть ли ошибка в обработке запроса
message string Сообщение об ошибке
paket number ID пакета

Вы можете воспользоваться Postman для отправки запросов

Postman JSON

пример кода на PHP

$ch = curl_init();
$url = "https://smsgateway24.com/getdata/getdata/addsms

$postarray = [
'token' => 'dsajdhjhj1ihi1',
'sendto' => '3782137192',
'body'   => 'SMS TEXT',
'timetosend'   => 'SMS TEXT',
];

 curl_setopt($ch, CURLOPT_URL, $url);
 curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
 curl_setopt($ch, CURLOPT_POST, 1);
 curl_setopt($ch, CURLOPT_POSTFIELDS,
 "postvar1=value1&postvar2=value2&postvar3=value3");
 curl_setopt($ch, CURLOPT_USERAGENT, 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13');
 $output = curl_exec($ch);
 curl_close($ch);
 echo $output;

                            

Пример кода для 1С

 Процедура ГлВыполнитьОтправкуСМС(Телефон,ТекстСМС) Экспорт


Логин=СокрЛП(Константа.ЛогинСМС);
Пароль=СокрЛП(Константа.ПарольСМС);
КодУстр=СокрЛП(Константа.КодУстройстваСМС);
Получатель=СокрЛП(Телефон);
Сообщение=СокрЛП(Лев(ТекстСМС,256));
Сообщение=ГлПреобразоватьСтрокуВУТФ8(Сообщение);

ТекстЗапроса="http://smsgateway24.com/getdata/smstosend?sendto="+Получатель+"&body="+Сообщение+"&device_id="+СокрЛП(КодУстр)+"&email="+Логин+"&pass="+Пароль;
Результат="";
Если ЗагрузитьВнешнююКомпоненту("c:\v7plus.dll") <> 1 Тогда
ТекстОшибки = "Компонента v7plus.dll не найдена!";
Сообщить(ТекстОшибки);
Возврат;
КонецЕсли;

Ошибка=0;
Соединение = СоздатьОбъект("AddIn.V7HttpReader");
Попытка
Соединение.ОтправитьДляОбработки(ТекстЗапроса,каталогиб()+"\temp.txt", 1,Результат, 2);
Исключение
Ошибка=1;
Сообщить("СМС не сформировано! для телефона "+Получатель+" Ответ сервера: "+Результат);
КонецПопытки;

Если Ошибка=0 Тогда
Сообщить("ОК. СМС сформировано! для телефона "+Получатель+" Ответ сервера: "+Результат);
КонецЕсли;


КонецПроцедуры
                            

Старый методы API (GET) (HTTPS + HTTP)

Отправка смс

Описание: Создает смс на сервере для отправки. После этого телефон с приложением Smsgateway24 обращается к серверу и забирает смс и отправляет со своей sim карты. Скачать приложение можно по ссылке : Ссылка на приложение SmsGateWay24

Адрес https://smsgateway24.com/getdata/smstosend?sendto=ТЕЛЕФОН&body=СООБЩЕНИЕ&device_id=ID_УСТРОЙСТВА&email=ЛОГИН&pass=ПАРОЛЬ

Адрес https://smsgateway24.com/getdata/smstosend?sendto=ТЕЛЕФОН&body=СООБЩЕНИЕ&device_id=ID_УСТРОЙСТВА&email=ЛОГИН&pass=ПАРОЛЬ&timetosend=2018-06-08 13:40:00

Метод: GET

входные параметры

Переменная Тип Описание
email string Ваш логин в системе. Обычно email
pass string ваш пароль
sendto string Телефонный номер абонента. Допускаются все требуемые символы. пример: +7-(928)-111-22-33
body string Тело сообщения для абонента
device_id string Id Устройства
timetosend datetime [YYYY-mm-dd HH:MM:SS] [не обязательно] Время отправки сообщения Например 2018-10-25 00:00:00

Ответ

"Saved" - Все окей
Access deny - не верный логин или пароль

PHP:

$ch = curl_init();
$url = "https://smsgateway24.com/getdata/smstosend?sendto=" . $save->phone . "&body=" . $body . "&device_id=" . $device_id . "&email=support@smsgateway24.com&pass=123456";
curl_setopt($ch, CURLOPT_URL, $url);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
curl_setopt($ch, CURLOPT_USERAGENT, 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13');
$output = curl_exec($ch);
curl_close($ch);

                        

Telegram Бот


Если вы хотите отправлять уведомления себе на телефон через телеграм, то подключите нашего бота

Отправить запрос

Описание: Отправляйте POST запрос на сервер а люди получат сообщение в telegram

перед тем как отправлять нужно сделать 3 шага:

  1. Скачать телеграм с официального сайта Telegram.org
  2. Что нибудь написать боту @Smsgateway24bot
  3. Узнать свой ID через бота @MyTelegramID_bot
  4. Отправить POST запрос

Адрес https://smsgateway24.com/getdata/telegrammessage

Сейчас Ваш токен: Вход

Метод: POST

входные параметры

Переменная Тип Описание
token string Ваш токен полученный из метода Получение токена
body string Тело сообщения для абонента
telegramid string Ваш Id в Телеграм через @MyTelegramID_bot

Ответ

Переменная Тип Описание
error number 0 / 1 - есть ли ошибка в обработке запроса
message string Сообщение об ошибке