Данный веб-сайт использует файлы cookie для того, чтобы сохранить данные на вашем компьютере. Если вы продолжаете работать с этим веб-сайтом, мы предполагаем, что вы соглашаетесь с использованием файлов cookie.
Diese Seite verwendet Cookies, um Ihnen den bestmöglichen Service zu gewährleisten. Wenn Sie auf der Seite weitersurfen stimmen Sie der Cookie-Nutzung zu.
Cookies remember you so we can give you a better service online. By using this website or closing this message, you are agreeing to our Cookies notice.
This site uses cookies to give you the best service possible. If you continue browsing, you agree to the use of cookies. Cookies remember you so we can give you a better service online. By using this website or closing this message, you are agreeing to our cookies notice.

SmsGateWay24.com Dein persönliches SMS-Gateway

SmsGateway24.com | Dokumentation Postman-link


Wenn Ihr Service das Senden einer Anfrage über SSL (über https) nicht unterstützt, können Sie das HTTP-Protokoll verwenden

Ein Token erhalten

Description: Das Ergebnis dieser Abfrage erhalten Sie ein Token. Mit diesem Token greifen Sie in Zukunft auf den Server zu und führen andere Anfragen aus.

Adresse https://smsgateway24.com/getdata/gettoken

Jetzt dein Token: Einloggen

Methode: POST

входные параметры

Variable Typ Description
email string Ihre Anmeldung im System. Normalerweise E-Mail
pass string Ihr Passwort im System

die Antwort

Variable Typ Description
token string Ihr Token für Anfragen. Token ist mit einem Konto verknüpft
error number 0 / 1 - is there an error in processing the request
message string Fehlermeldung


SMS senden

Description: Создает смс на сервере для отправки. После этого телефон с приложением Smsgateway24 обращается к серверу и забирает смс и отправляет со своей sim карты. Скачать приложение можно по ссылке Verknüpfen Sie mit der SmsGateWay24-Anwendung

Adresse https://smsgateway24.com/getdata/addsms

Methode: POST

входные параметры

Variable Typ Description
token string Ihr Token, erhalten mit der Methode Get Token
sendto string Telefonnummer des Teilnehmers Alle erforderlichen Zeichen sind erlaubt. Beispiel: + 49- (176) -111-22-33
body string Der Nachrichtentext des Abonnenten
device_id string Geräte ID
timetosend datetime [YYYY-mm-dd HH:MM:SS] [optional] Zeit zum Senden einer Nachricht, zum Beispiel 2018-10-25 00:00:00

die Antwort

Variable Typ Description
error number 0 / 1 - is there an error in processing the request
message string Fehlermeldung


Tag hinzufügen

Description: Das Tag wird benötigt, um einen Newsletter für eine Gruppe von Nummern zu erstellen. Zum Beispiel tag * Mitarbeiter *.

Adresse https://smsgateway24.com/getdata/savetag

Methode: POST

входные параметры

Variable Typ Description
token string Ihr Token, erhalten mit der Methode Get Token
title string Tag-Name

die Antwort

Variable Typ Description
error number 0 / 1 - is there an error in processing the request
message string Fehlermeldung
tag_id number Tag ID

Fügen Sie Kontakte mit einem Tag hinzu

Description: Fügen Sie Kontakte für jedes Tag hinzu. Zum Beispiel für das Tag * Mitarbeiter * werden Ihre Kollegen perfekt passen.

Adresse https://smsgateway24.com/getdata/savecontact

Methode: POST

входные параметры

Variable Typ Description
token string Ihr Token, erhalten mit der Methode Get Token
fullname string Kontaktname
phone string Telefonnummer
tag_id number Tag-Name

die Antwort

Variable Typ Description
error number 0 / 1 - is there an error in processing the request
message string Fehlermeldung
contact_id number Kontakt-ID

Erstellen Sie einen Newsletter

Description: Sobald Sie das Tag erstellt haben, können Sie das Mailing auf den Tag-Telefonen durchführen.

Adresse https://smsgateway24.com/getdata/savepaket

Methode: POST

входные параметры

Variable Typ Description
token string Ihr Token, erhalten mit der Methode Get Token
title string Newsletter-Titel
device_id number Geräte ID
body string Der Nachrichtentext des Abonnenten
tags string ID-Tag kann mehrere, durch Kommas getrennt sein. Zum Beispiel: 12,13,14

die Antwort

Variable Typ Description
error number 0 / 1 - is there an error in processing the request
message string Fehlermeldung
paket number Paket-ID

Sie können Postman verwenden, um Anfragen zu senden.

Postman JSON

PHP-Codebeispiel

$ch = curl_init();
$url = "https://smsgateway24.com/getdata/getdata/addsms

$postarray = [
'token' => 'dsajdhjhj1ihi1',
'sendto' => '3782137192',
'body'   => 'SMS TEXT',
'timetosend'   => 'SMS TEXT',
];

 curl_setopt($ch, CURLOPT_URL, $url);
 curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
 curl_setopt($ch, CURLOPT_POST, 1);
 curl_setopt($ch, CURLOPT_POSTFIELDS,
 "postvar1=value1&postvar2=value2&postvar3=value3");
 curl_setopt($ch, CURLOPT_USERAGENT, 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13');
 $output = curl_exec($ch);
 curl_close($ch);
 echo $output;

                            

Beispielcode für 1C

 Процедура ГлВыполнитьОтправкуСМС(Телефон,ТекстСМС) Экспорт


Логин=СокрЛП(Константа.ЛогинСМС);
Пароль=СокрЛП(Константа.ПарольСМС);
КодУстр=СокрЛП(Константа.КодУстройстваСМС);
Получатель=СокрЛП(Телефон);
Сообщение=СокрЛП(Лев(ТекстСМС,256));
Сообщение=ГлПреобразоватьСтрокуВУТФ8(Сообщение);

ТекстЗапроса="http://smsgateway24.com/getdata/smstosend?sendto="+Получатель+"&body="+Сообщение+"&device_id="+СокрЛП(КодУстр)+"&email="+Логин+"&pass="+Пароль;
Результат="";
Если ЗагрузитьВнешнююКомпоненту("c:\v7plus.dll") <> 1 Тогда
ТекстОшибки = "Компонента v7plus.dll не найдена!";
Сообщить(ТекстОшибки);
Возврат;
КонецЕсли;

Ошибка=0;
Соединение = СоздатьОбъект("AddIn.V7HttpReader");
Попытка
Соединение.ОтправитьДляОбработки(ТекстЗапроса,каталогиб()+"\temp.txt", 1,Результат, 2);
Исключение
Ошибка=1;
Сообщить("СМС не сформировано! для телефона "+Получатель+" Ответ сервера: "+Результат);
КонецПопытки;

Если Ошибка=0 Тогда
Сообщить("ОК. СМС сформировано! для телефона "+Получатель+" Ответ сервера: "+Результат);
КонецЕсли;


КонецПроцедуры
                            

Alte Methoden (GET) (HTTPS + HTTP)

SMS senden

Description: Создает смс на сервере для отправки. После этого телефон с приложением Smsgateway24 обращается к серверу и забирает смс и отправляет со своей sim карты. Скачать приложение можно по ссылке : Verknüpfen Sie mit der SmsGateWay24-Anwendung

Adresse https://smsgateway24.com/getdata/smstosend?sendto=TELEFON&body=NACHRICHT&device_id=Geräte_ID&email=LOGIN&pass=PASSWORD

Adresse https://smsgateway24.com/getdata/smstosend?sendto=ТЕЛЕФОН&body=СООБЩЕНИЕ&device_id=ID_УСТРОЙСТВА&email=ЛОГИН&pass=ПАРОЛЬ&timetosend=2018-06-08 13:40:00

Methode: GET

входные параметры

Variable Typ Description
email string Ihre Anmeldung im System. Normalerweise E-Mail
pass string Dein Passwort
sendto string Telefonnummer des Teilnehmers Alle erforderlichen Zeichen sind erlaubt. Beispiel: + 49- (176) -111-22-33
body string Der Nachrichtentext des Abonnenten
device_id string Geräte ID
timetosend datetime [YYYY-mm-dd HH:MM:SS] [optional] Zeit zum Senden einer Nachricht, zum Beispiel 2018-10-25 00:00:00

die Antwort

"Saved" - Alles Gut
Access deny - Falsche Login oder Passwort

PHP:

$ch = curl_init();
$url = "https://smsgateway24.com/getdata/smstosend?sendto=" . $save->phone . "&body=" . $body . "&device_id=" . $device_id . "&email=support@smsgateway24.com&pass=123456";
curl_setopt($ch, CURLOPT_URL, $url);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
curl_setopt($ch, CURLOPT_USERAGENT, 'Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13');
$output = curl_exec($ch);
curl_close($ch);

                        

Telegram bot


Wenn Sie Benachrichtigungen per Telegramm an Ihr Telefon senden möchten, dann verbinden Sie unseren Bot

Anfrage senden

Description: Senden Sie eine POST-Anfrage an den Server und die Leute erhalten eine Nachricht in einem Telegramm

Bevor Sie senden, müssen Sie 3 Schritte ausführen:

  1. Lade ein Telegramm von der offiziellen Seite herunter Telegram.org
  2. Etwas zum Bot schreiben @Smsgateway24bot
  3. Holen Sie sich Ihre ID über den Bot @MyTelegramID_bot
  4. Senden Sie eine POST-Anfrage

Adresse https://smsgateway24.com/getdata/telegrammessage

Jetzt dein Token: Einloggen

Methode: POST

входные параметры

Variable Typ Description
token string Ihr Token, erhalten mit der Methode Get Token
body string Der Nachrichtentext des Abonnenten
telegramid string Ihre ID zum Telegramm über @MyTelegramID_bot

die Antwort

Variable Typ Description
error number 0 / 1 - is there an error in processing the request
message string Fehlermeldung